Docker working Dynamo Revit plugins not connecting

Hi,

I have a Speckle server up and running in a Docker container. Just updated the container and Dynamo and Grassshopper plugins to Speckle-v1.7.14.234. In a browser go to the URL http://190.148.121.125:3000/#/ and get the login in page. Login in successful and see all the streams. Its working in the browser

In both Grasshopper and Dynamo the ‘manage accounts’ button will not see the URL as valid. Also tried http://190.148.121.125:3000/api/v1. Has the URL changed?

image

thanks for any help

I can’t seem to reach the server; a quick way to test is to go at yourserverurl/api and you should see a response on the lines of this:

{
    "isSpeckleServer": true,
    "serverName": "Speckle Hestia",
    "version": "1.x.x",
    "api": {
        "projects": [
            {
                "method": "POST",
                "route": "https://hestia.speckle.works/api/projects"
// ...

The important bit is isSpeckleServer: true. Is that there? If the server’s internet facing, ping me its url & i can take a look.

HI Dimitrie, thanks for the reply!

The response is below:

{
“serverName”:“NYC Docker Speckle Server”,
“version”:“1.x.x”,
“api”:{
“projects”:[
{
“method”:“POST”,
“route”:“undefined/api/projects”
},
{
“method”:“GET”,
“route”:“undefined/api/projects”
},
{
“method”:“GET”,
“route”:“undefined/api/projects/admin”
},
{
“method”:“GET”,
“route”:“undefined/api/projects/:projectId”
},
{
“method”:“PUT”,
“route”:“undefined/api/projects/:projectId”
},
{
“method”:“PUT”,
“route”:“undefined/api/projects/:projectId/addstream/:streamId”
},
{
“method”:“DELETE”,
“route”:“undefined/api/projects/:projectId/removestream/:streamId”
},
{
“method”:“PUT”,
“route”:“undefined/api/projects/:projectId/adduser/:userId”
},
{
“method”:“DELETE”,
“route”:“undefined/api/projects/:projectId/removeuser/:userId”
},
{
“method”:“PUT”,
“route”:“undefined/api/projects/:projectId/upgradeuser/:userId”
},
{
“method”:“PUT”,
“route”:“undefined/api/projects/:projectId/downgradeuser/:userId”
},
{
“method”:“DELETE”,
“route”:“undefined/api/projects/:projectId”
}
],
“clients”:[
{
“method”:“POST”,
“route”:“undefined/api/clients”
},
{
“method”:“GET”,
“route”:“undefined/api/clients”
},
{
“method”:“GET”,
“route”:“undefined/api/clients/:clientId”
},
{
“method”:“PUT”,
“route”:“undefined/api/clients/:clientId”
},
{
“method”:“DELETE”,
“route”:“undefined/api/clients/:clientId”
},
{
“method”:“GET”,
“route”:“undefined/api/streams/:streamId/clients”
}
],
“streams”:[
{
“method”:“POST”,
“route”:“undefined/api/streams”
},
{
“method”:“GET”,
“route”:“undefined/api/streams”
},
{
“method”:“GET”,
“route”:“undefined/api/streams/admin”
},
{
“method”:“GET”,
“route”:“undefined/api/streams/:streamId”
},
{
“method”:“PUT”,
“route”:“undefined/api/streams/:streamId”
},
{
“method”:“DELETE”,
“route”:“undefined/api/streams/:streamId”
},
{
“method”:“POST”,
“route”:“undefined/api/streams/:streamId/clone”
},
{
“method”:“GET”,
“route”:“undefined/api/streams/:streamId/diff/:otherId”
},
{
“method”:“GET”,
“route”:“undefined/api/streams/:streamId/objects”
},
{
“method”:“GET”,
“route”:“undefined/api/streams/:streamId/clients”
}
],
“accounts”:[
{
“method”:“POST”,
“route”:“undefined/api/accounts/register”
},
{
“method”:“POST”,
“route”:“undefined/api/accounts/login”
},
{
“method”:“GET”,
“route”:“undefined/api/accounts”
},
{
“method”:“GET”,
“route”:“undefined/api/accounts/admin”
},
{
“method”:“PUT”,
“route”:“undefined/api/accounts”
},
{
“method”:“GET”,
“route”:“undefined/api/accounts/:userId”
},
{
“method”:“PUT”,
“route”:“undefined/api/accounts/:userId”
},
{
“method”:“POST”,
“route”:“undefined/api/accounts/search”
}
],
“comments”:[
{
“method”:“GET”,
“route”:“undefined/api/comments”
},
{
“method”:“GET”,
“route”:“undefined/api/comments/assigned”
},
{
“method”:“POST”,
“route”:“undefined/api/comments/:resourceType/:resourceId”
},
{
“method”:“GET”,
“route”:“undefined/api/comments/:resourceType/:resourceId”
},
{
“method”:“GET”,
“route”:“undefined/api/comments/:commentId”
},
{
“method”:“PUT”,
“route”:“undefined/api/comments/:commentId”
},
{
“method”:“DELETE”,
“route”:“undefined/api/comments/:commentId”
}
],
“objects”:[
{
“method”:“GET”,
“route”:“undefined/api/streams/:streamId/objects”
},
{
“method”:“POST”,
“route”:“undefined/api/objects”
},
{
“method”:“POST”,
“route”:“undefined/api/objects/derive”
},
{
“method”:“GET”,
“route”:“undefined/api/objects/:objectId”
},
{
“method”:“POST”,
“route”:“undefined/api/objects/getbulk/”
},
{
“method”:“PUT”,
“route”:“undefined/api/objects/:objectId”
},
{
“method”:“PUT”,
“route”:“undefined/api/objects/:objectId/properties/”
},
{
“method”:“DELETE”,
“route”:“undefined/api/objects/:objectId”
}
]
},
“plugins”:[
{
“name”:“Speckle Admin”,
“version”:“0.7.5”,
“desc”:“YEAH! Speckle has a frontend yo!”,
“serveFrom”:"/",
“serveSource”:“plugins/admin/dist”,
“author”:“Speckle Project Contributors”,
“contact”:“hello@speckle.works”,
“homepage”:“https://speckle.works”,
“git”:“https://github.com/speckleworks/SpeckleAdmin”,
“sourceDir”:“plugins/admin”,
“canonicalUrl”:“undefined/”
},
{
“name”:“Sample Plugin”,
“version”:“0.1.0”,
“desc”:“This plugin tests plugins”,
“serveFrom”:"/sample-plugin",
“author”:“DAS”,
“contact”:"test@dimitrie.org",
“homepage”:“https://dimitrie.org”,
“git”:“https://github.com/speckleworks/SpeckleViewer”,
“sourceDir”:“plugins/speckle-sample-plugin”,
“canonicalUrl”:“undefined/sample-plugin”
}
]
}

It seems like there’s a wee bit of a confusion. If you’ve updated the docker container then this is weird. I suspect it’s to do with the fact that with @antoinedao we switched to proper tagged releases, rather the confusing latest tag.

Hence, the latest release, compatible with the latest upgrades, is 1.8.0. Let us know if this works out!

Hello Dimitrie,
I have a Speckle server up and running in a Docker container and I can login successfully and see all the streams and projects, when I try add an account in the Revit plugin and put server url the add account button is always disable, can you figure out what seems to be the problem?

Steps that I made for install Speckle Server:
1 - Create an account at DigitalOcean
2 - Create a droplet for Docker and configure the firewall for port 3000
3 - Clone this repo git clone https://github.com/speckleworks/SpeckleServer.git
4 - Go to the directory SpeckleServer
5 - Run the command docker-compose up

Thanks, Ricardo

Can you send me a screenshot of your URL? If you don’t want to share it here, message me privately.

Hello Dimitrie,

Of course I can share. I send a screenshot of the URl in the browser and another one of the Revit Plugin.

Thanks.

Oh, I think it’s just a matter of removing the “#” from the end! Did you try that?

If that fails, for the time being, you can always use the manual login:

  • log in in the browser and copy the token displayed
  • in the account manager from Revit/Dynamo click “Manually add the account” at the bottom of the window

Hello,

I try the first option from Dimitri but the problem persist. With the suggestion of Teocomi I can add a account but when I create a sender I receive a message telling that I could note access to the server.
I need to make any change in the file docker-compose.yml file before execute docker-compose up?

as far as i can see from your server’s API documentation response, you’re actually using an old image of the server.

This is our fault; you’ve probably pulled down latest which is not latest anymore. Please use a tagged release, the latest one is 1.9.2: https://hub.docker.com/r/speckle/speckleserver/tags

I will try to delete the latest tag now to avoid future confusion. Sorry! [Edit: done]

Hello,

I create a new Droplet for making a new fresh installation, change the docker-compose.yml for install the release 1.9.2.
Now I can´t access to the Speckle Server from the browser, I send a attached screenshot from the console.

In the Revit Plugin a create a account without any problem but when a try create and send a stream I continue receiving a message telling that I could note access to the server.

Hello Ricardo! I’ve just managed to create an account :slight_smile:

You can access the server from https://app.speckle.systems and login with http://159.65.92.128:3000/ as a server url. It works a bit like slack workspaces…

Hello Dimitrie,

Speckle Server from the browser ok,
Using the Dynamo plugin and creating a sender and receiver works fine.
Using the Revit Plugin when I try create and send a stream I continue receiving a message telling that I could note access to the server.

:point_up_2: this is what i’m getting as errors from the revit ui.

Can you confirm? You can open the dev console by clicking on the “CK” from “SPECKLE” in the top bar.

Ok, i think we tracked down the issue; we’ll need to enable non-https requests in cef.

In the meantime, if you use a domain name and add a SSL certificate (via letsencrypt!) - there’s good of tutorials on Digital Ocean on how to do this, and a guide here - this will not be an issue anymore (and the internet will be a safer place!).