Speckle Schema Builder Component Grasshopper Structural Elements Missing

Hello,

Quick question here…

My Schema Builder Component for structural elements seems to be incomplete. How can I get them back?

Heya @dirksliepenbeek! Can’t answer directly, but I’ll try and ping the people who might know :slight_smile: Here we go:

@teocomi released a new Speckle 1.x version recently, are you on that? (1.8.3).

From what I’ve been following around, @nicburgers and @HughGrovesArup just had a massive upgrade on the SpeckleStructuralKit - https://github.com/speckleworks/SpeckleStructural/pull/21

Since we’re not really managing that kit, I can’t tell you what happened, but I’m sure the folks pinged here will let you know!

@dimitrie thanks for the quick response, yes I’m on the latest version :smiley:

There’s one quick way to try and see if it’s the latest release’s problem:

Tested it till \SpeckleStructural-1.0.3.10… without success, any other way to test further?

Not that I know of :frowning: We’ll need to wait for @daviddekoning and/or @nicburgers to see what’s up.

Unless @teocomi has better ideeas, I’m out of them…

If those disappeared after the latest update I could suggest trying the previous stable release 1.8.24… Sorry for the hassle!

That’s a quick fix, all working now. :grinning:

1 Like

Hi @dirksliepenbeek, that’s very strange. Can you try installing the latest SpeckleStructuralSuite? https://github.com/arup-group/specklestructuralsuite-installer/releases (we released a new version last Friday, but I forgot to announce it :frowning: )

1 Like

Just installed, no success with latest version of Speckle :frowning:

ok, thanks - we’ll have a look

1 Like

@daviddekoning any luck on this? i have the same problem.

Hi @dirksliepenbeek and @Chris.Barker - I am not able to reproduce this. Have you tried re-installing the SpeckleStructuralSuite?

Hi David,

Yes have tried it, also with different versions. I am working in another Speckle version which has solved the problem.

2 Likes

Reverting to the previous version of speckle solved the problem for me too.

1 Like

Hi - reporting the same issue here with Speckle 1.8.31

Hi @AndrewBlackie - did you reinstall SpeckleStructuralInstaller after upgrading the Speckle client installer?

Hi David, I’ve haven’t had a chance to try that yet as I’m on a deadline at the moment - I reverted to a previous version in the mean time. Once I have some free time I’ll try upgrading again and report back.

1 Like

Hi @dirksliepenbeek, @Chris.Barker and @AndrewBlackie - we are still seeing this pop up intermittently, and I have been trying to reproduce the error (unsuccessfully).

If you are still seeing the problem (or can reproduce it by installing the latest version), could you:

  1. install MetaHopper
  2. open this GH file and post back the output

The GH file shows which version the speckle grasshopper plugin is being used, and hunts around for a list of speckle plugins that might be present on your computer.

If this turns up old versions of some speckle plugins, deleting the older versions may resolve the issue.
This will help us understand if the problem is due to multiple versions of the plugins interacting badly.

you can also check if the following folder is empty %LOCALAPPDATA%\SpeckleKits\SpeckleStructural.