Layers not showing correctly in speckle viewer


#1

hi, I am having an issue viewing object meshes with same geometry purposefully put on separate layers.

one layer ‘zones’ denoting the sufaces to a zone and one layer for surfaces and a another for windows

the zones layer is showing fine and but the other layers ticked to visible are not showing:

zones layer turned off but other layers which are on are not showing:

!

ideally what i want is when i turn the zones layer it should look like this when i turn off the zone layer:

i have tried 2 approaches regarding layers below which both have the same result, don’t know if that makes a difference

some other information that may be of use

there are
120 objects in the zone layer
2 in openings layer
84 in surfaces

206 objects with 3 layers
https://hestia.speckle.works/api/streams/eXP7dM7y2
https://hestia.speckle.works/api/streams/eXP7dM7y2/objects

206 objects with 206 layers
https://hestia.speckle.works/api/streams/6GlP9kwuk
https://hestia.speckle.works/api/streams/6GlP9kwuk/objects


#2

ok sorted this please ignore and delete. it was a stupid scaling issue on my side


#3

I was just hacking looking at this, and by the love of ${deity}, it looked proper! Happy to see it got sorted…


#4

And as a thing, I would stay away from actual stream layers as much as possible - they’re useful when sending or receiving things in grasshopper/rhino/dynamo, but a massive PITA otherwise.

That extra classification you had could be sorted via an extra per-object property, say GBXML_Type="opening" / "surface" / "zone";. Maybe this makes your life easier, maybe not :smiley: