Create Speckle Object component doesn't work with trees

Hi There!

I was playing a bit with Speckle2.0.
Trying to create more than one Base object with grasshopper, I noticed that the component works well with a list but it actually do nothing if the input is a tree.

1 Like

Hi @iltabe ! Thanks for pointing that out :slight_smile: I’m going to look into it during the day and get back to you.

1 Like

Hey @iltabe, I just tested with our latest version in master and I can only seem to reproduce your behaviour in Rhino 7, but not in Rhino 6. Just to confirm, which version are you currently using?

Are you compiling the components directly from code? If so, could you try and pull the latest changes and see if this is still an issue?

If you installed the GH Connector from the manager’s handy buttons, could you try and see if simplifying the input tree works? I randomly tried it and it seemed to do the trick.

There is obviously something fishy going on there so I’ll have a deeper look to pinpoint the issue, but it you are in fact using the latest Rhino 7, that may be just it.

Hello Alan.
I’m testing it with rhino 6, not 7. But my master is from few days ago. I’ll try between tonight and tomorrow to pull and see if something change.

Thanks!

Thanks! Apparently Matteo has managed to reproduce that behaviour so we’re looking into it.

Could you also check if “simplifying” your data tree makes it work? That may give us a hint of what going on there…

Here how I can reproduce it:

  1. Place CreateSpeckleObject component
  2. Add Input parameter
  3. Connect a Series (Graphted): It works!
  4. Flatten the Series output, remove the flatten, graph again
  5. Disconnect the input cable
  6. Riconnect: Broken

Simplify doesn’t work for me.

1 Like

Thanks for the detailed description! I can reproduce the issue with these steps, seems to be some sort of problem with how it’s handling component iterations internally.

I’m already looking at a potential fix so I’ll keep you posted.

1 Like

@iltabe, I just merged in some changes into the master branch that should fix the issue you were having. So feel free to pull the latest changes and give it a go! Let me know if that doesn’t do the trick still.

2 Likes

Ehy @AlanRynne,
Everything works perfectly now!
Thanks for the fast support!

2 Likes